読者です 読者をやめる 読者になる 読者になる

rbenv でインストールした Ruby2.0.0 に切り替えて gem コマンドを使ったらエラー発生

rbenv install 2.0.0-p0

Ruby 2.0 をインストールし、

rbenv global 2.0.0-p0

Ruby 2.0 に切り替えて

gem list --local

を実行したら

ERROR:  Your gem push credentials file located at:

    /Users/tnakamura/.gem/credentials

has file permissions of 0644 but 0600 is required.

You should reset your credentials at:

    https://rubygems.org/profile/edit

if you believe they were disclosed to a third party.

というエラーが発生した。パーミッションを変更しないといけないみたいだ。

chmod 600 ~/.gem/credentials

を実行して、所有者だけが読み書き OK、 他のユーザーは操作を一切不可にしたら、 gem コマンドが使えるようになった。